Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/aleche35/boards.sethroberts.net/Sources/Load.php(183) : runtime-created function on line 3
No signatures due to spamming

sethroberts.net forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please read The End Game: Shutting Down the Forums in the "News, Polls, Announcements" subforum

Pages: [1] 2   Go Down

Author Topic: No signatures due to spamming  (Read 9560 times)

0 Members and 1 Guest are viewing this topic.

Seth Roberts

  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 2570
No signatures due to spamming
« on: April 02, 2011, 02:59:22 PM »

Many new members appear to have signed up so that they can put their signature in a search engine -- a common form of forum spamming. I have changed the options: signatures of more than 1 letter are no longer allowed.
Logged

2monkeymom

  • Newbie
  • *
  • Offline Offline
  • Posts: 15
Re: No signatures due to spamming
« Reply #1 on: April 09, 2011, 01:27:11 PM »

How do we do a ticker, then?
Logged


Seth Roberts

  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 2570
Re: No signatures due to spamming
« Reply #2 on: April 09, 2011, 05:27:38 PM »

How do we do a ticker, then?
good question. I have changed the maximum-signature-length setting. Now you should be able to do a ticker.
Logged

Tandoori Trilobite

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 434
  • Aspiring gutless wonder
Re: No signatures due to spamming
« Reply #3 on: April 09, 2011, 10:04:21 PM »

Hi, Seth.  I think there might be a little more adjustment required.  I just tried editing my signature block, and noticed that the length restriction is now lifted.  However, if you have a BBCode img item in your signature block (which everyone will need for a ticker to be displayed), and you then save the signature block code, the board is forcing an unsolicited width=1 (pixel) and/or height=1 parameter into the img tag, thus rendering the image invisible.  I've been experimenting with displaying images from various places in my signature block, and there doesn't seem to be a way for a board user around the unwanted one-pixel width/height issue, which is likely waiting to bite the next time that someone updates their ticker.
Logged

Seth Roberts

  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 2570
Re: No signatures due to spamming
« Reply #4 on: April 09, 2011, 10:46:47 PM »

Tandoori, I put the signature restriction to exactly what it was earlier. So now it should work.
Logged

Tandoori Trilobite

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 434
  • Aspiring gutless wonder
Re: No signatures due to spamming
« Reply #5 on: April 09, 2011, 10:57:02 PM »

Maybe it's something to do with the revised board software, Seth -- or a bug?  I can edit my signature block code as I please, but once I hit the Change profile button, the board re-inserts the width and/or height parameters into the img tag.  I normally get by just fine with HTML or BBCode on message boards, but this issue's got me beat.
Logged

Tandoori Trilobite

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 434
  • Aspiring gutless wonder
Re: No signatures due to spamming
« Reply #6 on: April 09, 2011, 11:13:16 PM »

Seth, when I was editing my signature block code just before my previous post, it was continuously displaying how many characters' space I had left for it.  Now when I'm editing my signature block code, there's nothing telling me how many characters' space I have left, so I guess that demonstrates that you really have lifted the length restriction.  However, even if I explicitly set width or height parameters for the img tag, the board is still changing them on me (back to a width/height of one pixel) once I hit the Change profile button.
Logged

Seth Roberts

  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 2570
Re: No signatures due to spamming
« Reply #7 on: April 09, 2011, 11:58:38 PM »

Hmm. I am unable to find a setting that would cause that problem (height or width of 1 pixel). What can you tell me about when it began?
Logged

Tandoori Trilobite

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 434
  • Aspiring gutless wonder
Re: No signatures due to spamming
« Reply #8 on: April 10, 2011, 12:13:01 AM »

Well, once I saw that you had originally set a length restriction of one character in an attempt to thwart the spambots, I didn't attempt to edit my signature block code.  I could see that, as soon as I brought up the edit-profile page, the text in the signature code edit box was replaced by a single "[", so I simply backed out of the page.

When I saw today that you had lifted the restriction, I again brought up the edit-profile page, saw that the text in the signature code edit box was staying as it previously was, so I felt confident to edit it -- so, I only noticed the problem today.

(By the way, you'll have seen a request from me for a second account.  Nothing sinister intended -- I was just going to test whether the problem is peculiar to my present account, and then delete the second account.)
Logged

Son_Of_Tandoori_Trilobite

  • Guest
Re: No signatures due to spamming
« Reply #9 on: April 10, 2011, 12:52:57 AM »

Seth, I've just tried it with this alter ego account -- by copying the signature block code from my normal account into this one -- and I'm getting exactly the same issue.  Then I removed the "Placeholder ..." text from between the url tags -- leaving just the img code between the latter, as would normally be the case in my signature block -- and the weird behaviour persists.

So, it doesn't appear to be confined to my normal account.  I guess all that can be done now is to see if the same phenomenon is experienced by someone else setting/editing img tags in their signature block to accommodate a ticker update.

(If there's no need to keep this alter ego account around for further testing purposes, I'll blow it away tomorrow, or you can blow it away yourself.)
« Last Edit: April 10, 2011, 01:57:50 AM by Son of Tandoori Trilobite »
Logged

Seth Roberts

  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 2570
Re: No signatures due to spamming
« Reply #10 on: April 10, 2011, 04:56:56 AM »

Thanks for the investigation. At the moment I'm mystified. I may be able to get help on the SMF forums...
Logged

2monkeymom

  • Newbie
  • *
  • Offline Offline
  • Posts: 15
Re: No signatures due to spamming
« Reply #11 on: April 10, 2011, 11:49:07 AM »

Tandoori has described the original issue (single character limit) and the img tag forced dimension issue. The second issue seems to also be affecting the display of any graphics on the board.
Logged


Seth Roberts

  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 2570
Re: No signatures due to spamming
« Reply #12 on: April 10, 2011, 01:28:23 PM »

Tandoori has described the original issue (single character limit) and the img tag forced dimension issue. The second issue seems to also be affecting the display of any graphics on the board.
Thanks, that may help me find the problem.
Logged

Seth Roberts

  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 2570
Re: No signatures due to spamming
« Reply #13 on: April 10, 2011, 02:55:10 PM »

I changed something that may get rid of the size restriction on img links in signatures.

Logged

Tandoori Trilobite

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 434
  • Aspiring gutless wonder
Re: No signatures due to spamming
« Reply #14 on: April 11, 2011, 03:08:03 AM »

AAAZZZ
Logged
Pages: [1] 2   Go Up
 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18